Jump to comments

Change to browser requirements

Roan Lavery

CEO, Co-founder

In the next couple of weeks FreeAgent will stop supporting older versions of Internet Explorer.

In January 2016, Microsoft officially stopped support for all versions of IE below IE 11, meaning they will no longer receive security updates and technical support.

So that we can maintain the highest levels of security for our users and continue to improve FreeAgent, we will be ending support for older versions of Internet Explorer from 15 August 2016. After that date you will need to upgrade your browser to access your account.

Using the latest stable version of Internet Explorer (or indeed any browser) with FreeAgent will mean you always get the safest, fastest and most reliable experience.

You can download the latest version of Internet Explorer or try Chrome or Firefox if you’re feeling particularly adventurous. Go on, live a little!

Yours, on the edge
Roan and the team at FreeAgent

Sign up for regular tips, offers and news updates.

We are committed to keeping your information safe. Read our Privacy Policy to find out more.

Related Articles

Got questions?